• Lập trình Visual Basic căn bản - Phần 3Lập trình Visual Basic căn bản - Phần 3

    Method Circle Ta dùng Method Circle để vẽ hình tròn, hình bầu dục và đường cung, với bên trong trống rỗng hay được sơn đầy bằng một màu ta chỉ định. Ta phải cho biết tọa độ của tâm điểm vòng tròn và bán kính của nó. Bạn hãy khởi động một dự án VB6 mới, đặt lên form một button với tên frmCircle và caption Circle & Lines. DoubleClick lên button ấ...

    doc69 trang | Chia sẻ: dntpro1256 | Ngày: 23/11/2020 | Lượt xem: 1238 | Lượt tải: 1

  • Lập trình Visual Basic căn bản - Phần 2Lập trình Visual Basic căn bản - Phần 2

    Để cho chương trình thú vị hơn, khi user clicks nút Animate, ta sẽ cho một box màu đỏ chạy từ trái qua phải. Khi user clicks nút Two Boxes ta sẽ vẽ hai boxes, hộp trong màu xanh, hộp ngoài màu đỏ, và cho chúng chạy từ trái sang phải. Ở đây ta biểu diễn cho thấy mình muốn instantiate bao nhiêu boxes từ clsBox cũng được, và dĩ nhiên mỗi box có một ...

    doc53 trang | Chia sẻ: dntpro1256 | Ngày: 23/11/2020 | Lượt xem: 1288 | Lượt tải: 1

  • Lập trình Visual Basic căn bản - Phần 1Lập trình Visual Basic căn bản - Phần 1

    Function là một dạng subroutine giống giống như Sub. Chỉ khác ở chỗ Function cho ta một kết quả, cho nên cách dùng Function hơi khác với Sub. Ta viết một variable bên trái dấu =, được assigned kết quả của một Function. Thí dụ như ta dùng Trim Function để loại bỏ những blank space ở hai đầu của text string TString: ResultString = Trim(TString) T...

    doc44 trang | Chia sẻ: dntpro1256 | Ngày: 23/11/2020 | Lượt xem: 1213 | Lượt tải: 1

  • Lập trình hướng đối tượng với C - Chương 2: Biểu thức (Expression) - Đại học Cần ThơLập trình hướng đối tượng với C - Chương 2: Biểu thức (Expression) - Đại học Cần Thơ

    Toán Tử Điều Kiện, Phẩy & Lấy Kích Thước Toán tử điều kiện min = (m < n ? m++ : n++); Toán tử phẩy min = (m < n ? mCount++, m : nCount++, n); Toán tử lấy kích thước cout << "float size = " << sizeof(float) << " bytes\n";

    ppt8 trang | Chia sẻ: dntpro1256 | Ngày: 23/11/2020 | Lượt xem: 1375 | Lượt tải: 1

  • Giáo trình Quản trị mạng - Chương 6: NAGIOS - Bùi Minh QuânGiáo trình Quản trị mạng - Chương 6: NAGIOS - Bùi Minh Quân

    Thêm các dịch cần giám sát trên Agent Thêm các dịch vụ cần kiểm tra trên client: Thêm nội dung vào cuối file  Thêm command_check vào file /etc/nagios/nrpe.cfg Kiểm tra các Script đã có trên Agent chưa ? Nếu Script kiểm tra chưa có?  Tìm và download script: namescript  Chuyển script vào /usr/lib/nagios/plugins/  Cấp quyền thực thi cho s...

    pdf40 trang | Chia sẻ: thucuc2301 | Ngày: 23/11/2020 | Lượt xem: 1830 | Lượt tải: 2

  • Lập trình môi trường Windows - Font và String - Phạm Thị VươngLập trình môi trường Windows - Font và String - Phạm Thị Vương

    Mô tả lớp TextRenderer - Cung cấp phương thức cho việc đo lường và thay đổi hình thức hiển thị của chuỗi văn bản - Không cho phép kế thừa - Namespace: System.Windows.Forms - Assembly: System.Windows.Forms (in system.windows.forms.dll)

    pdf116 trang | Chia sẻ: dntpro1256 | Ngày: 23/11/2020 | Lượt xem: 1249 | Lượt tải: 1

  • Giáo trình Quản trị mạng - Chương 5: Simple Network Management Protocol Management (tiếp theo) - Bùi Minh QuânGiáo trình Quản trị mạng - Chương 5: Simple Network Management Protocol Management (tiếp theo) - Bùi Minh Quân

    Tạo người dùng SNMPv3  Ubuntu Server: 172.30.102.141  Down load: net-snmp-create-v3-user tar xvzf net-snmp-create-v3-user.gz chmod +x net-snmp-create-v3-user sudo mv net-snmp-create-v3-user /usr/local/bin Bài tập SNMPv3  Ubuntu Server (172.30.102.141): tạo người dùng  sudo net-snmp-create-v3-user -a SHA -A NetManage admin  sudo net...

    pdf44 trang | Chia sẻ: thucuc2301 | Ngày: 23/11/2020 | Lượt xem: 1348 | Lượt tải: 2

  • Giáo trình Quản trị mạng - Chương 5: Simple Network Management Protocol Management - Bùi Minh QuânGiáo trình Quản trị mạng - Chương 5: Simple Network Management Protocol Management - Bùi Minh Quân

    SNMPv3  RFC3411, RFC3412, RFC3413, RFC3414, RFC3415.  Mục tiêu: tăng cường bảo mật cho giao thức SNMP  Xác thực user (user authentication): giao thức MD5,SHA  Mã hóa thông tin (message encryption): ngăn ngừa xem trái xem, sử dụng giao thức DES hoặc AES SNMPv3  SNMPv3 rất phức tạp và cồng kềnh  Là sự lựa chọn tốt nhất cho vấn đề bảo mậ...

    pdf27 trang | Chia sẻ: thucuc2301 | Ngày: 23/11/2020 | Lượt xem: 1167 | Lượt tải: 1

  • Lập trình môi trường Windows - GDI+ (Graphic Device Interface) - Phạm Thị VươngLập trình môi trường Windows - GDI+ (Graphic Device Interface) - Phạm Thị Vương

    Lớp Matrix của GDI+ có sẵn tất cả các phương thức cần thiết để thao tác trên ma trận biến đổi. – Multiply: nhân một ma trận biến đổi với ma trận hiện tại – Scale: nhân một ma trận dãn với ma trận hiện tại – Shear: nhân một ma trận kéo với ma trận hiện tại – Translate: nhân một ma trận dịch chuyển với ma trận hiện tại – Rotate: nhân một ma trậ...

    pdf47 trang | Chia sẻ: dntpro1256 | Ngày: 23/11/2020 | Lượt xem: 1192 | Lượt tải: 1

  • Giáo trình Quản trị mạng - Chương 4: Network Managerment - Bùi Minh QuânGiáo trình Quản trị mạng - Chương 4: Network Managerment - Bùi Minh Quân

    Quản lý hiệu suất (Performance management) FCAPSQuản lý hiệu suất  Nhiệm vụ xác định:  Những loại ứng dụng nào hiện có, và những yêu cầu QoS của ứng dụng là gì ?  Lưu lượng dữ liệu đền từ đâu ?  Lưu lượng dữ liệu đi đâu ?  Có thắt cổ chai, nếu có, ở đâu ?  Cung cấp các mức độ chấp nhận của hiệu năng (SLA) khi lưu lượng mạng thay đổi. ...

    pdf38 trang | Chia sẻ: thucuc2301 | Ngày: 23/11/2020 | Lượt xem: 1532 | Lượt tải: 3